17/06/2021
Mise à jour de DCS en version 2.7.2.7910.1
Mise à jour de SRS en version 1.9.7.0

  • Membre du bureau

    Bonjour, chers mission-makers.

    TL;DR: pour passer à la version 3.0.0 des outils VEAF, merci d’aller voir à la fin de ce post.

    Explication

    Si vous utilisez les outils VEAF (build.cmd, extract.cmd, etc.) vous dépendez du package NPM veaf-mission-creation-tools, qui contient tous les scripts lua et les programmes en node.js.

    Lors de l’appel à build.cmd, npm va aller chercher la dernière version de ce package, en se basant sur ce qui est demandé dans le fichier package.json.
    Ici, on demande une version (ou plutôt un ensemble de versions) spécifiques, en utilisant une syntaxe particulière qui se base sur le semantic versionning.

    Par exemple, dans VEAF-Open-Training-Mission , le fichier package.json contient la ligne suivante :

      "dependencies": {
        "veaf-mission-creation-tools": "^2.30.0"
      }
    

    Ceci demande à NPM d’aller chercher toutes les versions compatibles avec la version 2.30.0, à savoir :
    bb07525f-e617-4815-ad7d-bd5c7e9427b5-image.png
    (schéma obtenu sur ce site)

    Version 3.0.0

    Vous pouvez constater que la dernière version (3.0.0) n’est pas considérée comme compatible, à raison.
    J’ai choisi de passer à une nouvelle version majeure parce que j’ai supprimé la librairie Moose, et que donc votre mission existante ne fonctionnera plus (il manquera ce script).

    Comment passer à la dernière version

    Pour passer à la dernière version, il faut supprimer les triggers qui font référence à Moose.lua dans votre mission :

    e61897b9-32a4-4114-98eb-a9cefb0bcab6-image.png

    a3c1ddc4-78f6-4f27-82a2-de5727603ac5-image.png

    Puis il faut éditer le fichier package.json pour autoriser la version 3.x.x :

      "dependencies": {
        "veaf-mission-creation-tools": "^3.0.0"
      }
    

    Et enfin relancer le script build.cmd.